Jul 24

why does the print head go over the edge

6 comments

when doing the test print if it was to print the test line it would be doing that off the bed,so how do i move the head back to where it would be on the bed and doing that test line.

Is the head going over during printing, or during bed levelling? During bed levelling this is normal, as the calibration is done adjusting the probe to be where the print head will be during printing. If it's during printing, and you are using the DSE, make sure you have the print bed offset properly as mentioned in step 15 of stage 2 of the regular assembly manual.

as far as i know the bed is where it should be,and yes it was during printing or attempting to print

@Daryl Smith Somewhere in cura software, in the machine configuration there is section where you can introduce gcode before or after the printing start. This code is being run before your printing starts and somehow the coordinates or the distances that are being executed in a way that your test line is outside the bed. So, this code has to be modified a little bit to avoid this error. Have you tried downloading all the software again and flashing? If after this it stills happens it could be a problem in how your printers calculates how far it has to move since seems only you got the problem(you can see this printing a test and using measuring tools). If you need a better answer ask again.

thanks for the help. umi have no idea on programming,so is there any numbers in the config that u can offer me to use or compare to mine?or where to look.?

@Daryl Smith ok, I will give you more information about the gcode soon, but I have to insist first, have you try flashing all the software again(arduino, toushcreen, and downloading cura again)? we need to discard this first.

 

Another thing that comes into mind is that when you choose wish printer you have first time using Cura (proforge 2, proforge 2s, proforge 2s dual....) you have to choose the one you build! For example if you haven't build de dual extruder then you have to select "proforge 2s" as your printer, not the "proforge 2s dual extruder " option.

 

Check this things before getting in the code, because code is more difficult and almost everyone get it to work without this error. Check the building guide again if necessary.

Aug 12
Top Comment

So gcode...l its a kind a programming language but more primitive. Its like giving specific instruction to the printer with code difficult to recognize, but it doesn't have much logic like general programming will have. Gcode programs are read once from top to bottom by the machine, no repeating code neither thinking by the 3d printer.

 

Stage 11, step 5. Here you can see the machine settings menu. To the bottom left the gcode executed before the printer stars and to the bottom right the code that is run after the print stops. You can add all sort of crazy stuff in here.

https://makertech-3d.dozuki.com/Guide/Stage+11+-+First+Print/17?lang=en

 

Lets analyze the following gcode, this is my starting gcode and should me equal to most people:

;----------Proforge 2S Start G-code----------
M201 X900 Y900 Z50 E5000
M140 S{material_bed_temperature_layer_0} ;Set Bed Temp
M104 S{material_print_temperature_layer_0} T0; Heat up Hotend 1 (T0)
M109 S{material_print_temperature_layer_0} T0; Wait for Hotend 1 (T0)
G28 ;Home
G29 ;Autolevel Bed
G1 F8000 X10 Y3 ;Move hotend to bottom left corner
G1 Z3 ;Move Hotend to assumed Z Home

; ---Unique to your setup---
G92 Z0.47 ;Set Z-offset in 0.1mm incriments (increase if first layer too high, decrease if too low)
; --------------------------

G1 Z{layer_height_0} ;Set to first layer height
M82 ;absolute extrusion mode
G92 E0 ;Zero Extruder
G1 F1500 X290 E12 ;Prime Hotend
; ----------Proforge 2S Start G-code----------

 

Pretty strange code isn't it? But thanks to Makertech that made a comment in each line we can figure this out faster, check this part of the code:

G29 ;Autolevel Bed
G1 F8000 X10 Y3 ;Move hotend to bottom left corner
G1 Z3 ;Move Hotend to assumed Z Home

First line seems to call to the autolevel function, this will trigger the 9 point readings. Question, is the probe(blue thing) always on top of the bed surface when you are printer autolevels?

 

Second line is the code we wanna change, this code tells the extruder to move to this point, somehow in your setup Daryl this is making your extruder go too far. So you have to investigate in the internet what each of this codes "G1 F8000 X10 Y3" means and modify the numerical values to a value that works for you. You can test this codes with pronterface remember, Stage 10:

https://makertech-3d.dozuki.com/Guide/Stage+10+-+Programming/16?lang=en

 

So test playing with this code in pronterface and if you find out values that work for you then change the machine settings so you get a correct test line before printing. Unless you like living a dangerous life research the codes before using them in pronterface.

 

I don't really know gcode, you have to study it and solve the problem yourself =), but I can guide you if you have more doubts or problems, just ask. And if someone knows gcode and what I just said is wrong then please correct me hehe xD.

 

New Posts
  • Hi, I am attempting to complete Stage 10 Step 7. When I connect the control board to the computer USB port, I don't get any lights and the port doesn't show up in Arduino. I have tried 2 different computers, I have also tried connecting directly with the blue cable into the control board, rather than through the extension cable. With the same result. No lights showing. Directly connected and no lights. If anyone has any ideas I would appreciate trying them.
  • I am building the Proforge 2S with dual extruders and the heated bed upgrade and at stage 10, step 15 (https://makertech-3d.dozuki.com/Guide/Stage+10+-+Programming/15?lang=en) i see all 3 icons(heated bed, and both extruders) but only Extruder 2 shows the correct ambient temprature. Extruder 1 shows -15c and the heated bed show 166. To verify that the thermistors are working i tried to connect each and every one of them to the Extruder 2 pinout on the board and they all show their respective ambient tempratures, confirming that the thermistors work individually. However no matter what thermistor i connect to the other 2 connectors on the controller, i get no other reading. Do i have to enable something in the arduino code to enable the other ports on the controller? Someone suggested to swap the polarization of the sensors, but this left me with the same result. Additionally preheating the bed or any of the extruders does not change their temprature (using my fingers to feel if they get warm). I measured the powersupply and see good voltages. Has anyone else ran into this?
  • Look like I've got a dead servo. Tests failed on DSE Stage 07 - Switching Arm and Z-Offset I'll arrange for a replacement.