Apr 14

Servo motor is no more working

12 comments

After having made a first calibration print, I tried to make a new one with adjuted parameters but the servo is no more working. It was no more able to turn to select the Hotend #1. So, I turned off the printer and made again the calibration procedure for the servo. I discovered that it can turn to select the Hotend #2 but it can no more turn in the other way.

Is the servo already broken?

How can I solve this problem?

I also now have the same issue. It was switching without issue through the number selection on the touchscreen previously. I did a print of the low profile fan shrouds, the raft printed with hotend #1 and the shrouds with hotend#2 with no issue. TI went to start another print and it started to try to print without switching to hotend #1. Cancelled and tried to switch back to hotend#1, the x/z adjustment occurs but no servo action. Turned it off manually reset servo to hotend #1, system worked to switch to #2 but still wouldn't switch back to #1, so the servo is still working, just not all the time... (you can see the z-axis motor going during the switch attempts in the bottom corner)

 

 

I have the same issue too.

It worked the first time i've press 3 button, and aftert that, only x/z adjustment occurs.

Adeel, Can you help us with this problem ? This make us unable to use the DSE.

I do have a very similar problem with the servo. It worked fine on initial setup and was switching finde from Position 1 to 2 and 3 before the first print.

Initiating the first print for DSE setup just as mentioned in the build guide I had a very strange and loud sound which I think was when my Servo died. Now it wont react to any commands. Also in Pronterface I can send commands wich M280 P3 SXX and receive the corresponding degree when sending M280 P3. However, the servo is not moving any more. I guess that is a strong indication my servo died? Thank you very much in advance for any help on this!

It seems that many people are having troubles with the servo dying after a few switches or that certain positions stop to be working on the touchscreen after some time or the first prints. Might the firmware or some setup in cura cause the servo to die? Once I receive the replacement servo, anything I can do to make sure this one will live any longer?

Same here. Could not complete my first dual color print. it seems to me that the stoping angles are not spot on......

May 10

I do have the exact same problem. Ordered a new servo using the RMA form and it is on it's way... it doesn't seem like a software issue, right?

I am also having the same issue- identical to the 1-2-3 ‘buttons’ being reported on the touchscreen. Has anyone been able to get this fixed? What RMA for are you referring to? I have emailed them twice now to ask for direction in this and have no response yet.

With my replacement servo I used Pronterface to finetune the servo ankles (details described in the build manual comments) on positions 1 and 2 and changed the values accordingly in configuration.h (Arduino IDE).

Had no trouble with servo since then and I have printed quite a bit...

Also having the same problem. Should I just replace the servo or is there any workaround? Thanks in advance.

 

Kind regards

Tinus

Aug 28

Hello,

Same for me. Upgrading the Proforge 2S with the DSE. It was working fine until stage 8, then it was no more able to turn to select the Hotend #1. I did the configuration again from the begining but it's not working anymore.

So, should I just replace the servo or is there any workaround ? I sent two email to Makertech but still no reply so far. Thanks in advance.

Sep 16

I'm getting the same problem with the servo getting jammed when switching positions. Is it worth getting another servo with higher torgue?

New Posts