Jun 16

Hotend_Offset_Y

2 comments

Edited: Jun 16

Has anyone had issues getting the y-axis offset calibrated on the dual head extruder? My single material prints are beautiful but the second nozzle is about +1mm off in the y and I have tried modding the offset in the firmware by 2mm and it is still the same, like it had little to no effect. Is there anything else I have to adjust to make it take? I already adjusted my z-offset with great success.

 

 

 

 

Jun 16Edited: Jun 16

Did you modify the firmware to enable EEPROM? I was having the same issue since the EEPROM settings being loaded were overriding my firmware changes. Either do an M502 to load from configuration.h and redo all your changes, or skip the firmware and do M218 T1 Y#.## to change it from console commands and then M500 to save to EEPROM. This is also generally easier to dial it in since there's no reflashing the firmware to get it where you really want it.

 

Edit: Are you sure you are referring to the Hotend_Offset_Y and not Hotend_Offset_Z? The build manual only has you set Z, and X/Y are done in Cura during calibration prints.

Thanks! Yes, I did when I was experimenting with the octoprint gcode commands because reflashing takes forever. I think the only thing I haven't copied into the eeprom from the config file is this setting so I will try that tonight.

New Posts
  • Is there any way to configure this to display current activity? As in showing X,Y and Z position and possibly Layer height, plus fan and temps? After setup, it is fairly useless during printing. My other printer uses Ramps and larger display, the active print info is displayed.
  • When loading and unloading filament, there is no cancellation-button. Also i have not found any way to move the filament just a little. When unloading filament, i have had the filament stop due to the end of the filament being a small blob. i have then removed the ptfe tube from the extruder driver side, but the blob is to far in for me to reach with my cutters, so i need to feed the filament out a little. Being able to do this with either loading and then cancelling, or by manually feeding a little bit would be handy. I am not sure if this is something we could potentially change ourself, i have not dove into the marlin side of the printer, but if someone would add that functionality, that would be neat.
  • I have the Proforge 2S and have completed all installation steps up to Stage 10, as I cannot get the control board to show as a serial port. When I have the USB connected, the red LED on the control board is solid on, and blue blinks for a moment with the initial boot. In addition to that, the X and Y end stops do turn on their LED when triggered, so I know power is transferring. I have attempted this with two different computers, both running up-to-date Windows 10 and the latest driver downloads from the website, although neither register the device as anything, let alone a serial port. I have used the provided USB cable and one of my own both through the extender to the back of the printer base and directly into the control board. Does anyone have any ideas on what to try now?