Apr 12

Printing stops

66 comments

the object i was printing was an Apple Watch charging dock. The Chac Mool one from MyMiniFactory. I've tried printing it 4 separate times. each time the print just stops. Initially i thought it was getting stuck. But having just witnessed the stopping. i now know that is not the case. the printer freezes. it claims the hotend and bed are still at printing temp though they are cooling and soon cool to touch. i have tried shutting down and resuming print but the carriage locates incorrectly and lowers too far crashing into the print and dislodges it from the bed. seems to happen after the 3-4 hours of printing mark.

 

anyone have any ideas. this is really becoming frustrating. i'm going to try another long print. i seem to remember it happening on another but not positive so i will try it to be sure its not the file.

Apr 12

Bueller, Bueller...

 

anyway continues to happen, no matter the file or slicing software. after about 2 1/2 hours now of printing it freezes. i'vegotthe printer hanging over an edge with a fan directed at the underside. hoping it would help if it was freezing due to an over heating issue. but no avail. the problem persists.

 

any help here would be great. or someway to start troubleshooting the problem.

 

thanks in advance

Apr 14

1. Does printing stop at the exact same spot each time?

Yes - Likely a gcode issue, try copying the gcode to the SD card with a different computer/SD card reader/writer.

No - Printer firmware or touchscreen firmware issue.

2. Are you printing via octoprint?

Yes - Try disconnecting the touch screen, it might be causing a conflict.

3. Do you have a computer connected whilst printing?

Yes - Disconnect from the computer.

 

Things you can try:

1. Using a different SD card/formatting the SD card to a smaller file size.

2. Disconnecting the touchscreen and printing via Octoprint only or via a wired computer connection.

Apr 22

#Makertech

 

1: no it doesn't stop at the the same spot each time. i've tried it on the same file and its stopped at 4 different stages of the print. max i've got was around 80% with the lowest being around 17%.

2: no i have not setup my octoprint yet. been trying to work out the bugs before i add another thing to the printer.

3: i've tried it whilst both connected and disconnected. with each stopping at different points.

 

i will try printing with the touchscreen disconnected as i haven't tried that yet.

 

as well as trying a different SD card as the only one i've been using is the one supplied.

 

which formatted file structures are you wanting me to try

Apr 15

well i've loosened the guide wheels on both the platform and the carriage. initially they came loose. so i tighten them. but the platform i'm sure i over tightened. so now i went through tightened the wheels just enough that they engage the extruded aluminum. both are traveling more freely.

 

but i do not know if this fixed my problem. since my switching servo died on me and i flat out refuse to disassemble the carriage for a second time to put the single hotend back together for a third time to disassemble it for a third time to reassemble it for a third time when my replacement servo shows up. plus a lead on one of the a parts fan has already broken off from the multiple re/dis/assemblies i've performed.

Mine is doing the same, a couple different files all stop around an hour and a half to two hours into printing. Same symptoms

Apr 29Edited: Apr 29

I've had this happen a few times, although I'm also getting a lot of 20+ hour prints going fine too when things work. Two microSD cards, two different microSD to SD adapters and a fullsized SD card, all verified with h2testw for capacity and write/read errors. Restarting the printer after one of these freezes puts the progress back at 0% so 'resume' starts from the beginning of the print with bed leveling. The last time it happened I just removed and reinserted the SD card into the touchscreen reader after restarting the printer and on the reprint it went without a problem. Is there a way to add something like simple MD5/CRC integrity checks to the gcode files in the firmware/printer interface to make sure it isn't corrupted before loading? I already do it on my computer when transferring the files to the SD cards, but there's clearly another point of failure on reading the file back on the printer.

Apr 30

well i was able to pull off a 6.5 hour print without it stopping. to it would seem i had the guide wheels causing too much friction from them being adjusted too tightly against the 2020 extruded aluminum. the only issue i had was a layer shift early on. pretty sure its an unrelated issue.

Just had the same issue... At 32% on a 1h17 print, the printer just stops completely.

I pressed "options" and tried "pause", which make the touchpanel freeze up.

 

Then I turned the printer off and back on, which brought it back to the "pause" screen.

I pressed resume, at which point the printer started heating up the hotend and board and then it dug itself into the print bed... seems "resume" is not the right approach.

 

We're looking into trying to recreate this issue as it sounds like it could be either temperature control related or touch screen firmware related. Hope to have software updates out soon to hopefully resolve the issue.

I'll try a few times more with the same GCode and if it keeps failing, will send you the file

@Makertech I tried another print last night, stopped at 41%. Started a new one this morning and my wife just reported it hangs at 72%. I will send the GCode when I get home tonight and will flash a single hotend firmware over the weekend to give that a try (since I haven't replaced my servo yet, I effectively have a single hotend anyway ;-) ) To be continued...

Load more replies

I'm getting this issue too with my DSE. Specifically, I'm attempting to print something with supports using PVA as the support material. It seems to freeze after switching back to the main material the first time. It prints the raft, and the first layer of both materials, then freezes. I've tried re-making the file on my SD card to make sure the file didn't get corrupted somewhere several times to no avail.

Same here, i'm experiencing random freezes, let's say 1 out of 6, different gcodes and at different stages. When it happens, it's impossible to quit/resume, pause/resume or do anything else other than power off/on and restart the print. Seems like a software crash.

I've now gotten a freeze at the same point on a previously working gcode(a temperature tower) left on the sd card several times since I switched filament rolls(same brand). Tried another SD Card and verified the gcode checksum, no other changes. Currently running single extruder and single firmware, so it's not explicitly a DSE thing. Restarting the print after a power cycle begins from 0% and either does Home All and bed leveling again, or goes back to printing dozens of layers above where it crashed out, extruding filament into thin air.

For the record: using Octoprint zero hangs/freezes.

May 17Edited: May 18

I started experiencing the same issues (print stopped after approx 2h at 92%) no reaction and no resume possible. Firmware was just updated yesterday (touchsceen, marlin as well as cura). Any hints?

 

May 22

Things to try:

Printing with the filament sensors disconnected.

Printing with a different SD card or copying the gcode to the sd card with a different reader/writer, especially likely to be the cause if printing stops again at the same place.

 

Also:

Was a PC connected to the printer whilst printing?

Was octoprint connected?

Disconnecting the filament sensors did not solve the problem either. Could this be related to higher temperature when printing PET? I only had this problem printing on Extruder 2 with PET (Both hotends @210 Degrees and Heated Bed at 85 Degrees). Does not really depend on the file I am printing it seems - aber out 20 minutes in the printer freezes... Printer hangs up and does not resume even when starting new. Seems when freezing the hotends and the printbed stop heating ...

@denishungnguyen this should not have been sent out with this many problems.i still want a refund.instead of a door stop

 

@daryl smith So far I feel that Adeel is very supportive and responsive dealing with the problems and I still hope that with a few tweaks I'll get it running stable. Overall impressed of the precision and happy with the printing results. Stability of the system is what's missing and I hope this can and will be fixed by a software or firmware update..

Load more replies
May 29Edited: May 29

I still experience the random freezes (not at the exact same spot and trying different SD Cards) - specially when printing on hotend 2 only (no nozzle switching within the print, Temp 210). No PC connected, no Octoprint connected. Happend twice now on a 27 minute print between 80 and 92%. Any suggestions what to do?

Ok, so I switched material and on hotend 1 the PETG prints just fine even for >4h. What might cause the printer to stop when printing on hotend 2 only? Should I re- upload the touchscreen firmware? Had not used the reset button when updating previously...

Jun 16

still getting the occasional stops but i've been able to print 2 prints that were over 24 hours each. and a few at 18+ hours. theres no rhyme or reason for the stops as i started an 18 hour print. it stopped about 5% in. i reloaded the print started it and it printed fine full 18+ hours. little more than cancelling the stopped print and just starting it again. i did that to see if there was a file issue but it seems that wasn't the case.

i will say it seems to happen more often from a cold start. meaning if i turn on the printer and start the print quickly. but if i turn the printer on and let it sit for a while before i start the print. it seems to not happen as often. maybe just a coincidence, idk. i've also had success with preheating everything before i start the print. again may just be coincidence.

Jun 18Edited: Jun 18

How much variance do you have on your hotend when it's at temp? I had to do some changes to the thermal runaway/cold extrusion prevention settings in the firmware because my hotend swings +/- 15 degrees or more over 5 second windows. If the hotend is too far away compared to the set temperature for more than the set window(which I think is 6 degrees for 60 seconds by default in configuration_adv.h) the thermal runaway kicks in and the print stops and all heating elements turn off. Also near that is the WATCH_TEMP_PERIOD settings which sets a window (20 seconds) where it needs the temperature to increase by 2 degrees after any M104/109/303 command or it gives a heating failed error and needs a hard reset to recover - this one comes up more in printing with both hotends as there are a lot more M104 commands there. In my case this was happening a lot due to a combination of factors where my hotend would sit at 198/205 or below for a long period due to some wonky with the PID tuning between two hotends and just hard stop without the touchscreen catching the error. You can see the error pop up in pronterface when printing via USB, but if you aren't actually at the printer when it happens the message log can scroll well beyond the error message from the automatic busy responses.

Jun 20

I have very little swing in temps. Maybe 10* overall. +/- 5* usually the larger swing is near initial preheat.

Your explanation sheds more/better light on the range issue I was trying to remember in my post below. I do usually have a fan running these days. Perhaps the constant breeze the printer is contending keeps a better consistency. An intermittent breeze(door/window opens, person/pet walking by, etc...) may cause too large of a swing at times. I don't know, just speculation. But it makes some sense. Taking a variable and making it a constant, so the variance is controlled.

 

Those are my thoughts and ramblings

Jun 16

i guessing here. but if i remember right before the firmware update. the issue they found was an overheating range issue. again i'm guessing here, but possible the power supply is overheating on certain circuits causing the shutdowns(stops). i would loosen all the eccentric nuts and slowly tighten till they just engage as needed, then make sure the servo isn't continually actuating. it should not be making any sound pr vibrate at all. i replaced my servo with an aftermarket one. i did several modifications to the mounting bracket and the servo to make the servo fit. But it was continually actuating. i slightly bent out the stop with a pair of pliers. just till the the servo quit trying to push against it i'm sure the modifications and bending this would void a warranty but its what i did. and as i've stated above i've had great success with my printing since.

I have experienced this behavior several times, I will even say that the frequency increased after last firmware update. Some notes about the behavior:

  • Extruder stops moving ,usually inside the print area, and temperature descends to ambient, no way to continue.

  • Touch screen responds to touch but printers doesn't move (cant pause neither stop print). Printer needs restarting and after it boots print shows at 0 % progress.

  • Can happen( or not) 20 minutes or 5 hours! in the first print of the day. (Maybe is not related to overheat)

  • Could be related to gcode, or no. (Got a case of printing freezing at the same point)

  • Happened since the first version of makertech software

 

This is really hard to debug. Someone knows a way to get more information when this happens? Anyone have experienced similar behavior? or have you not experienced a single freeze in several prints?

 

I will be testing with a different sdcard and writer, almost always my touchscreen freezes when inserting an sdcard when the printer is on. Also will look into what @Dataris Remiel said, seems that it could be a cause.

I need to do more testing but I think i got some info. After changing the printer to a corner and making an improvised enclosure I'm no longer having freezes that stops the print and that turn off bed and heater temperatures. However, I still got freezes where the temperature stays the same and I get a hot blob of melted plastic at freeze point, in this case in particular I can stop the printer without needing a reset. So maybe we got two kind of freezes:

 

  1. Change in temperature freezes. Printer unresponsive, temperature descend to ambient.

  2. Error in gcode maybe? Printer responds, temperatures stays high. Happens almost finishing the print?

 

Touchscreen freezes I was experiencing were because I had a movie in the sdcard that I didn't erase well (linux), make sure to use a clean card if you are experience troubles; but has anyone had other problems like this with sdcards?

maybe u can help seeing as there is no tech support,but when i try and print it does the test line off the table.how do i fix that.thanks

New Posts
  • I'm trying to raise to 130° (planning to print pom-c) but it goes up to 100° and then stops: (Error: Heating failed, system stopped! Heater_ID: bed - Printer halted. kill() called!) Has anyone tested the max temperature heated bed can reach? It's due to hardware limit?
  • Whilst trying to cure the lines in the print, it looks like I’ve turned the pots on the 2 TMC1200’s just ever so slightly too much clockwise (Too many volts). The display disappeared. I’ve since replaced the TMC1200’s and whilst the display works, there is still no movement on the XYZ axis’. I wish I had used a DVM to properly calibrate the volts instead of doing it by eyesight as the destructions suggested. As the XYZ doesn’t work, I’m lost to how to identify if it’s the main control board, display board, or something else. Anyone have any suggestions?
  • I'm getting layer shifting on the y axis. Sometimes it will do ~100 layers just fine, other times every 3rd layer or so seems to miss steps and get offset from the ones underneath it. I've checked the pulley lead screws are tight and the belt is properly tensioned. Do I need to adjust the stepper driver? How much and which way? The motor for the carriage seems underpowered.